Remove WordPress Bundled / Included jQuery

Recently, from version 3 and onwards WordPress has included or bundled a load of javascript with it, this is found in:  wp-includes/js/ This list includes scripts such as jQuery scriptaculous hoverIntent prototype colorpicker json swfobject and more. Unfortunately WordPress is forcing everyone to use jQuery version 1.4.2 with abit of a ignorant attitude, quote one…